commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <gil...@harfang.homelinux.org>
Subject Re: [Math] Issue 810
Date Mon, 02 Jul 2012 14:24:14 GMT
Hello.

> >
> > Please have a look at
> >   https://issues.apache.org/jira/browse/MATH-810
> >
> > [This will enable more natural usage in contexts where there is no notion of
> > "key" and "value".]
> >
> > Any objection?
> >
> >
> > Best,
> > Gilles
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> > For additional commands, e-mail: dev-help@commons.apache.org
> >
> 
> I'm +1 for this change. I would even write the patch the other way round
> 
> public K getKey() {
>   return getFirst();
> }
> 
> to emphasize that a Key, Value pair is just a particular case of a
> general pair. This is a bit nit-picking, though...

While I agree on the principle, we could just leave it as is for "historical
reasons". :-)


Regards,
Gilles

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message