commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [VFS] Update VFS trunk to Java 6
Date Sun, 17 Jun 2012 11:42:01 GMT
On 17 June 2012 03:40, Ralph Goers <ralph.goers@dslextreme.com> wrote:
>
> On Jun 16, 2012, at 2:26 PM, Gary Gregory wrote:
>
>> For now, I want @override so I am ok with 1.6 source but I is safe to
>> the have 1.5 target? Commons-io >=2.3 is not pressing for VFS.
>>
>> Gary
>
> Why would it not be? If that is all you are doing the @Override doesn't make it to the
actual Class.  See http://docs.oracle.com/javase/6/docs/api/java/lang/annotation/RetentionPolicy.html#SOURCE
for the retention policy used by @Override.

Does not work for me; just tried changing target for pool and running
"mvn clean compile":

[ERROR] BUILD FAILURE
[INFO] ------------------------------------------------
[INFO] Compilation failure
Failure executing javac, but could not parse the error:
javac: source release 1.6 requires target release 1.6

==

I'm not sure that wanting to use @Override for interface
implementations is a very good reason for requiring 1.6.

If there is new functionality in Java 1.6 that is required for VFS then fine.
But not for a minor annotation issue.

> Ralph
>
>>
>> On Jun 16, 2012, at 16:00, Ralph Goers <ralph.goers@dslextreme.com> wrote:
>>
>>> @Override is a compile annotation so we could have source be 1.6 and target 1.5
for that.  Do you have a pressing need to upgrade to commons-io 2.3?  If that is a necessity
than I am OK with upgrading to Java 6 for the target. IOW, I'm not in favor of upgrading just
because "Java 5 is dead" but because we actually have a requirement to do it.
>>>
>>> Ralph
>>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message