commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <garydgreg...@gmail.com>
Subject Re: [VFS] Update VFS trunk to Java 6
Date Sat, 16 Jun 2012 21:26:37 GMT
For now, I want @override so I am ok with 1.6 source but I is safe to
the have 1.5 target? Commons-io >=2.3 is not pressing for VFS.

Gary

On Jun 16, 2012, at 16:00, Ralph Goers <ralph.goers@dslextreme.com> wrote:

> @Override is a compile annotation so we could have source be 1.6 and target 1.5 for that.
 Do you have a pressing need to upgrade to commons-io 2.3?  If that is a necessity than I
am OK with upgrading to Java 6 for the target. IOW, I'm not in favor of upgrading just because
"Java 5 is dead" but because we actually have a requirement to do it.
>
> Ralph
>
>
> On Jun 15, 2012, at 7:46 AM, garydgregory wrote:
>
>> (posting from nabble as I've lost the thread in my inbox)
>>
>> I want to revive using Java 6 this for trunk. Java 5 is dead, no only is
>> forcing projects to update to the trunk stream from VFS 2.0.
>>
>> In addition to the list below:
>>
>> - Make VFS more attractive for new user/developers, new committers in the
>> 21st century. No one can force anyone to upgrade to the next version.
>> - Keep VFS relevant. The older versions are still there for volunteers to
>> patch.
>> - Open the door for newer versions of jars that required Java 6, like
>> commons-io 2.3.
>>
>> *I want to use Java 6 @Override on more methods which I find extremely
>> helpful.*
>>
>> Thank you,
>> Gary
>>
>> --
>> On Mon, May 14, 2012 at 9:20 AM, Ralph Goers <[hidden email]> wrote:
>>
>>> Thanks. We to we're taken by surprise by this as it was not discussed
>>> prior to the change. A
>>
>>
>> This has been backed out of SVN for now.
>>
>> (from the JIRA:)
>>
>> Whys:
>> - Make VFS more attractive for new user/developers, new committers in the
>> 21st century. No one can force anyone to upgrade to the next version.
>> - Keep VFS relevant. The older versions are still there for volunteers to
>> patch.
>> - Open the door for newer versions of jars that required Java 6, like
>> commons-io 2.3.
>>
>> Gary
>>
>>
>>> s a rule the minimum version should only be changed if something requires
>>> it. I'm waiting for a response from Gary as to why this was necessary
>>> before asking him to revert it.
>>>
>>> Ralph
>>>
>>> On May 14, 2012, at 2:50 AM, Andreas Persson <
>>> [hidden email]> wrote:
>>>
>>>>> FYI: I've updated VFS trunk to Java 6 to avoid getting stuck on older
>>>>> versions of jars and further moving VFS in the 21st century ;) Tasked
>>>>> as VFS-415.
>>>>
>>>> I was happy to see VFS-414 and VFS-313 being fixed, thank you very much
>>> for that! The change in VFS-415 however makes it impossible for us to use
>>> VFS 2.1 (we have several jboss 4 installations left, and jboss 4 doesn't
>>> support jdk 6). I just wanted you to know that there still are VFS users
>>> that depend on jdk 1.5 compatibility.
>>>>
>>>> /Andreas
>>>>
>>
>> --
>> View this message in context: http://apache-commons.680414.n4.nabble.com/VFS-Update-VFS-trunk-to-Java-6-tp4629464p4635119.html
>> Sent from the Commons - Dev mailing list archive at Nabble.com.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message