commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Brisard <>
Subject Re: [math] SparseRealVectorTest, SparseRealMatrixTest, SparseFieldMatrixTest, SparseFieldVectorTest
Date Mon, 28 May 2012 11:44:05 GMT

2012/5/28 Thomas Neidhart <>:
> On 05/28/2012 11:23 AM, Luc Maisonobe wrote:
>> Le 28/05/2012 09:42, Sébastien Brisard a écrit :
>>> Hi,
>>> is there a reason why these classes are called SparseXxxTest, instead
>>> of OpenMapXxxTest? Am I missing something?
>> I don't remember the reason, it may either be that we renamed the
>> library class and forgot to rename the test classes, or we intended to
>> share base test class accross several different implementations and did
>> not do it.
I'm currently looking into the tests of all vectors implementations,
and there is *a lot* of duplicate code. I will probably factor out
some of this code into the newly created RealVectorAbstractTest (which
I've set up for the sake of testing the various implementations of the
visitor pattern).

>> Nevertheless, they could be renamed for consistency. As they are only
>> test classes, there are no compatibility issues there.
>> Thanks for identifying this.
> fyi: there is already an issue about this MATH-625
> Thomas
Thomas, you are a living encyclopedia! Thanks for the hint, I you
want, I can take care of that ticket.

Best regards,

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message