commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <>
Subject Re: [math] Deprecating "guessParametersErrors"
Date Fri, 04 May 2012 14:40:47 GMT
> > [...]
> > For clarity's sake (design-wise), I propose to remove the
> > "guessParametersErrors" method, and add a "getSigma" (as syntactic sugar).
> >
> I'm OK with that. As a first step, we deprecate it, and stipulate in
> the javadoc that getSigma() should be used instead. We emphasize that
> both methods do not provide exactly the same value. Similarly, I
> propose that the javadoc of getSigma() states exactly what it returns
> (namely, sqrt(cov[i][i])). Finally, do you think its worth calling
> this method getSigmaParameters() in order to avoid confusion with sd
> on the observations (which are implicitly assumed by the weights in
> the chis-square)?
> The tests I've recently added (NIST data) must be altered a bit, so
> maybe I could take of the whole thing if you want.


> Then we could
> consider that MATH-784 is resolved.

Before closing the issue, I'd like to commit the "test" I've attached to
MATH-784. It's not really a "unit" test (as it doesn't "assert" anything
yet) but it shows the meaning of "sigma".
I've ended the class name with the string "TestValidation" so that it does
not run by default with the "test" target.]

Maybe I can add the assert statement (once the "getSigma" method is

Is that OK for everyone?


> [...]

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message