commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Brisard <>
Subject Re: [Math] Question about "AbstractLeastSquaresOptimizer" code
Date Mon, 30 Apr 2012 06:43:16 GMT
> Can we then agree that the current naming is not really clear?
> Since we are not allowed to readily remove this method, the best solution
> would be to update the Javadoc to make it clear what is done there, i.e.
> cite the full definition of ASE (together with a reference).

I would even go one step further
  - depreciate guessParametersErrors()
  - rename this method as getParametersStandardDeviation(), since the
implemented formula seems to be the accepted estimate for the sd of
the optimized parameters.

> Then, to further disambiguate, we could add a
>  double[] getSigma()
> method that will in effect return the (sqrt of the) diagonal elements of the
> covariance matrix.

I'm not sure, now. Indeed, sigma would suggest that the returned value
is the standard deviation, which it is not (see above). I must check
that the square root of the diagonal elements of the covariance matrix
(with no prefactor) are really meaningful from a statistical point of
view. If they are not, I suggest we do not provide any accessor.

What do you think?

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message