commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: [io] Moving to Java 6 for version 2.3
Date Fri, 30 Mar 2012 07:47:49 GMT
Hi Christian,

Christian Grobmeier wrote:

> Hi,
> 
> On Fri, Mar 30, 2012 at 1:53 AM, sebb <sebbaz@gmail.com> wrot
>> However, a compatibility break would require a major version bump.
> 
> if my lib does drop support for a specific jdk, isn't that a
> compatibility break? My argument is it is no longer compatible with
> jdk5.

The common rule has always been, that we're backward compatible, if you can 
replace the old jar with the new version. If this switch requires an upgrade 
of the environment, it's fine. The old version will (normally) run as well 
on the on the updated environment as the new one will. But the application 
itself has not to be modified or compiled.

> However, please do not consider my concerns a -1 on the version name,
> I am fine with 2.3 too.

Updating the major version is also always a signal to users for a migration 
effort. Chances are nowadays high, that we use a new package name ;-)

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message