commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <garydgreg...@gmail.com>
Subject Re: svn commit: r1298588 - /commons/proper/codec/trunk/src/test/java/org/apache/commons/codec/language/NysiisTest.java
Date Fri, 09 Mar 2012 18:58:41 GMT
On Fri, Mar 9, 2012 at 1:52 PM, Thomas Neidhart
<thomas.neidhart@gmail.com>wrote:

> On 03/09/2012 12:55 AM, Gary Gregory wrote:
>
> >>> This is why I added the 'trueLength' (lame name?) ivar because that
> seems
> >>> like a reasonable toggle after reading the Wikipedia entry.
>
> I changed it locally to 'cutOff', would you agree with this name change?
>

That's not a great name either :(

Wikipedia says: "If longer than 6 characters, truncate to first 6
characters. (only needed for true NYSIIS, some versions use the full key)"

What it does is "truncate to 6" but that is a pretty functional
description. I think a name that reflects "strict vs. not" or "normal vs.
long key" would be better.

Should the default be to truncate to 6?

Some choices:

- strict is best IMO
- fullKey
- shortKey

Gary


>
> Thomas
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>


-- 
E-Mail: garydgregory@gmail.com | ggregory@apache.org
JUnit in Action, 2nd Ed: <http://goog_1249600977>http://bit.ly/ECvg0
Spring Batch in Action: <http://s.apache.org/HOq>http://bit.ly/bqpbCK
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message