commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S├ębastien Brisard <sebastien.bris...@m4x.org>
Subject Re: [math] Package transform revisited
Date Thu, 09 Feb 2012 09:50:09 GMT
Hi Luc,
>
> I agree with you, enums are much better. There are other places in
> [math] where we use boolean or even ints for such things. They mainly
> came for pre-java 5 era when enums where not available.
>
> Luc
>
And what do you think of replacing
- transform(double[]) with transform(double[], FORWARD)
- inverseTransform(double[]) with transform(double[], INVERSE)
(also using enums) ?
In fact, at the lowest level, all transforms are coded this way (a
boolean is passed to specifiy whether or not the inverse is to be
computed). So maybe the higher level methods should also do so.
S├ębastien


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message