commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S├ębastien Brisard <sebastien.bris...@m4x.org>
Subject [math] Resolve MATH-677?
Date Wed, 01 Feb 2012 02:03:20 GMT
Dear all,
I think I've gone through all suggested changes in the package
transform (MATH-677). I've left two tasks (namely 3.1 and 3.3 in this
issue)
- Methods "mdfft" and "verifyDataSet" take an argument of type
"Object" (to allow an argument with an unspecified number of
dimensions).
- For clarity, multidimensional transform should be moved to a class
of its own (and I also wonder whether the
"MultiDimensionalComplexMatrix" name is not misleading).
Although these two changes are important, I think they require
thorough discussion, so now is probably not the best time. Also, I
think that the transform package will continue evolving (extension to
non-power of two numbers, multi-threading, ...), so I'd rather
postpone those remaining changes.
What do you think?
S├ębastien


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message