commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Brisard <sebastien.bris...@m4x.org>
Subject Re: [math] Package transform revisited
Date Fri, 10 Feb 2012 08:55:58 GMT
Dear all,

2012/2/9 Gilles Sadowski <gilles@harfang.homelinux.org>:
> On Thu, Feb 09, 2012 at 11:02:36AM +0100, Luc Maisonobe wrote:
>> Le 09/02/2012 10:50, Sébastien Brisard a écrit :
>> > Hi Luc,
>> >>
>> >> I agree with you, enums are much better. There are other places in
>> >> [math] where we use boolean or even ints for such things. They mainly
>> >> came for pre-java 5 era when enums where not available.
>> >>
>> >> Luc
>> >>
>> > And what do you think of replacing
>> > - transform(double[]) with transform(double[], FORWARD)
>> > - inverseTransform(double[]) with transform(double[], INVERSE)
>> > (also using enums) ?
>>
>> It's good too.
>
> +1
>
> Gilles
>
Please have a look to some comments I've made in MATH-743, if you can
spare some time.
Best regards,
Sébastien


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message