commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simone Tripodi <>
Subject Re: svn commit: r1238968 - in /commons/sandbox/beanutils2/trunk/src/main/java/org/apache/commons/beanutils2:
Date Wed, 01 Feb 2012 08:26:58 GMT
Guten morgen,

> I don't think that "onClassName" is a good name for that method, because fluent invocations
will look like:
> onClassName("java.lang.Object").invokeStaticMethod(...)...
> We do not invoke a method on a class name, but on a class. I think
> onClass(String className) is self-explanatory enough and it would be similar to invokeStaticMethod(String
> What do you think?

I think you didn't checkout the code and/or didn't have a look at how
methods are chained in the patch :)

onClassName( "com.acme.Something" ).loadWithClassLoader( myClassLoader

ˆˆˆˆˆˆˆˆˆˆhave a look at alternatives


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message