commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claudio Squarcella <>
Subject Re: [graph] renaming weight operations
Date Sun, 19 Feb 2012 13:59:40 GMT
Hello Simone,

> It would be much more naturally to my hears hearing it as
> BigDecimalOrderedMonoid, doesn't it?

you have a valid point. However my intention is to decouple 
implementations from underlying interfaces, because they might evolve 
and grow over time.

Let me give you two examples:

  * Doubles can also be multiplied, but so far we did not need to
    include that in our stack of operations and properties. If we ever
    need to do so, it will be enough to create another interface
    extending OrderedMonoid and change the implemented interface in
  * Also, there might be properties and/or operations that are unrelated
    to each other, hence DoubleWeightOperations might implement more
    than one interface in the future.

How does that sound?


Claudio Squarcella
PhD student at Roma Tre University

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message