commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <gil...@harfang.homelinux.org>
Subject Re: [math] Package transform revisited
Date Thu, 09 Feb 2012 12:08:06 GMT
On Thu, Feb 09, 2012 at 11:02:36AM +0100, Luc Maisonobe wrote:
> Le 09/02/2012 10:50, Sébastien Brisard a écrit :
> > Hi Luc,
> >>
> >> I agree with you, enums are much better. There are other places in
> >> [math] where we use boolean or even ints for such things. They mainly
> >> came for pre-java 5 era when enums where not available.
> >>
> >> Luc
> >>
> > And what do you think of replacing
> > - transform(double[]) with transform(double[], FORWARD)
> > - inverseTransform(double[]) with transform(double[], INVERSE)
> > (also using enums) ?
> 
> It's good too.

+1

Gilles

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message