commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <garydgreg...@gmail.com>
Subject Re: svn commit: r1293496 - /commons/proper/commons-parent/trunk/pom.xml
Date Sun, 26 Feb 2012 01:14:24 GMT
On Feb 25, 2012, at 19:18, sebb <sebbaz@gmail.com> wrote:

> On 25 February 2012 14:46, Gary Gregory <garydgregory@gmail.com> wrote:
>> On Sat, Feb 25, 2012 at 9:23 AM, sebb <sebbaz@gmail.com> wrote:
>>
>>> On 25 February 2012 14:11, Gary Gregory <garydgregory@gmail.com> wrote:
>>>> On Fri, Feb 24, 2012 at 8:23 PM, sebb <sebbaz@gmail.com> wrote:
>>>>
>>>>> On 25 February 2012 00:47,  <ggregory@apache.org> wrote:
>>>>>> Author: ggregory
>>>>>> Date: Sat Feb 25 00:47:00 2012
>>>>>> New Revision: 1293496
>>>>>>
>>>>>> URL: http://svn.apache.org/viewvc?rev=1293496&view=rev
>>>>>> Log:
>>>>>> Update plugins.
>>>>>>
>>>>>> Modified:
>>>>>>    commons/proper/commons-parent/trunk/pom.xml
>>>>>>
>>>>>> Modified: commons/proper/commons-parent/trunk/pom.xml
>>>>>> URL:
>>>>>
>>> http://svn.apache.org/viewvc/commons/proper/commons-parent/trunk/pom.xml?rev=1293496&r1=1293495&r2=1293496&view=diff
>>>>>>
>>>>>
>>> ==============================================================================
>>>>>> --- commons/proper/commons-parent/trunk/pom.xml (original)
>>>>>> +++ commons/proper/commons-parent/trunk/pom.xml Sat Feb 25 00:47:00
>>> 2012
>>>>>> @@ -193,12 +193,12 @@ Version 23:
>>>>>>         <plugin>
>>>>>>           <groupId>org.apache.maven.plugins</groupId>
>>>>>>           <artifactId>maven-antrun-plugin</artifactId>
>>>>>> -          <version>1.6</version>
>>>>>> +          <version>1.7</version>
>>>>>>         </plugin>
>>>>>>         <plugin>
>>>>>>           <groupId>org.apache.maven.plugins</groupId>
>>>>>>           <artifactId>maven-assembly-plugin</artifactId>
>>>>>> -          <version>2.2.1</version>
>>>>>> +          <version>2.3</version>
>>>>>>         </plugin>
>>>>>>         <plugin>
>>>>>>           <groupId>org.apache.maven.plugins</groupId>
>>>>>> @@ -262,7 +262,7 @@ Version 23:
>>>>>>         <plugin>
>>>>>>           <groupId>org.apache.maven.plugins</groupId>
>>>>>>           <artifactId>maven-release-plugin</artifactId>
>>>>>> -          <version>2.2.1</version>
>>>>>> +          <version>2.2.2</version>
>>>>>>         </plugin>
>>>>>>         <plugin>
>>>>>>           <!-- TODO see above - find better way to add N&L
files to
>>> jars
>>>>> and test jars -->
>>>>>> @@ -318,7 +318,7 @@ Version 23:
>>>>>>           <groupId>org.apache.felix</groupId>
>>>>>>           <artifactId>maven-bundle-plugin</artifactId>
>>>>>>           <!-- N.B. 2.3.5 does not work on Java 5; see profile
>>>>> java-1.5-detected for the workround -->
>>>>>> -          <version>2.3.5</version>
>>>>>> +          <version>2.3.6</version>
>>>>>
>>>>> Does 2.3.6 work with java 1.5?
>>>>>
>>>>> If so, maybe the work-round can be commented out or removed?
>>>>>
>>>>
>>>> Sure, that makes sense.
>>>>
>>>> Seems to be ok for me when I build [codec] with:
>>>>
>>>> Apache Maven 3.0.4 (r1232337; 2012-01-17 03:44:56-0500)
>>>> Maven home: C:\Java\apache-maven-3.0.4\bin\..
>>>> Java version: 1.5.0_22, vendor: Sun Microsystems Inc.
>>>> Java home: C:\Program Files\Java\jdk1.5.0_22\jre
>>>> Default locale: en_US, platform encoding: Cp1252
>>>> OS name: "windows 7", version: "6.1", arch: "amd64", family: "windows"
>>>>
>>>> I see:
>>>>
>>>> [INFO] --- maven-bundle-plugin:2.3.6:manifest (bundle-manifest) @
>>>> commons-codec ---
>>>>
>>>> No stack traces or errors.
>>>
>>> Need to check M2.2.1 as well.
>>>
>>
>> Build successful with:
>>
>> Apache Maven 2.2.1 (r801777; 2009-08-06 15:16:01-0400)
>> Java version: 1.5.0_22
>> Java home: C:\Program Files\Java\jdk1.5.0_22\jre
>> Default locale: en_US, platform encoding: Cp1252
>> OS name: "windows 7" version: "6.1" arch: "amd64" Family: "windows"
>
> Did you disable the java-1.5-detected profile?
>
> That is automatically enabled when running under Java 1.5, and selects
> earlier versions in order to fix this.

How do I disable it from the cli?

Gary
>
> Testing with Java 1.5 and bundle 2.3.6 does not prove anything unless
> the profile override is disabled.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message