commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <flame...@gmail.com>
Subject Re: [DBUTILS] Few unit tests for BeanProcessor; none for SQLXML support
Date Thu, 12 Jan 2012 08:20:13 GMT
Tell me why 1.6 is a problem again?

This is DB-helper code, so much less worried about use cases like Android.

Hen

On Fri, Jan 6, 2012 at 3:05 AM, sebb <sebbaz@gmail.com> wrote:
> I did some experimenting with BeanProcessor to see what would be
> involved in providing Java 1.5 support.
>
> As part of this, I tried commenting out the new code that requires Java 1.6.
>
> All tests still worked.
>
> I then commented out most of the rest of the else if clauses in the
> processColumn method, and the unit tests still worked.
>
> I think it might be fairly easy to recode the SQLXML section so it
> still works in Java 1.5, but without a proper unit test, this is
> difficult to prove.
>
> In any case, more unit tests are definitely needed.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message