commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Hendriks <D.Hendr...@tue.nl>
Subject Re: [Math] Package "integration" (related to MATH-707)
Date Tue, 31 Jan 2012 15:05:08 GMT
I may be overlooking something, but isn't 
"BaseAbstractUnivariateIntegrator" double, in the sense that "Base" and 
"Abstract" both refer to an abstract base class that actual integrators can 
derive from? In other words, wouldn't "BaseUnivariateIntegrator" or 
"AbstractUnivariateIntegrator" be enough?

Best regards,
Dennis


Brent Worden wrote:
> On Tue, Jan 31, 2012 at 7:15 AM, Gilles Sadowski
> <gilles@harfang.homelinux.org> wrote:
>> Hi.
>>
>> In order to resolve issue MATH-707, one last thing could be changed, to make
>> the whole "analysis" package self-consistent regarding the class naming
>> scheme: "UnivariateRealIntegrator" -> "UnivariateIntegrator"
>>
>> Also, the class "UnivariateRealIntegratorImpl.java" should be renamed. In
>> addition to removing the "Real" part from the name, I would change it to:
>>  "BaseAbstractUnivariateIntegrator"
>>
>> Do you agree?
>>
>>
>> Best regards,
>> Gilles
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
> 
> +1
> 
> Thanks,
> 
> Brent
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message