commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <gil...@harfang.homelinux.org>
Subject Re: [Math] Package "integration" (related to MATH-707)
Date Tue, 31 Jan 2012 16:11:57 GMT
On Tue, Jan 31, 2012 at 04:05:08PM +0100, Dennis Hendriks wrote:
> I may be overlooking something, but isn't
> "BaseAbstractUnivariateIntegrator" double, in the sense that "Base"
> and "Abstract" both refer to an abstract base class that actual
> integrators can derive from? In other words, wouldn't
> "BaseUnivariateIntegrator" or "AbstractUnivariateIntegrator" be
> enough?

I thought that a "Base" class might not necessarily need to be "Abstract".
Or, if we can assume that it is always so, then you are right; and I'd happy
to remove the "Abstract" string from the name, as it is redundant with the
"abstract" keyword in the class declaration.
The converse is not true: an "Abstract" class is not necessarily a "Base"
class, where "Base" is to be taken in the sense of "the most basic
functionality").

Best,
Gilles

> 
> 
> Brent Worden wrote:
> >On Tue, Jan 31, 2012 at 7:15 AM, Gilles Sadowski
> ><gilles@harfang.homelinux.org> wrote:
> >>Hi.
> >>
> >>In order to resolve issue MATH-707, one last thing could be changed, to make
> >>the whole "analysis" package self-consistent regarding the class naming
> >>scheme: "UnivariateRealIntegrator" -> "UnivariateIntegrator"
> >>
> >>Also, the class "UnivariateRealIntegratorImpl.java" should be renamed. In
> >>addition to removing the "Real" part from the name, I would change it to:
> >> "BaseAbstractUnivariateIntegrator"
> >>
> >>Do you agree?
> >>
> >>
> >>Best regards,
> >>Gilles

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message