commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Grobmeier <grobme...@gmail.com>
Subject Re: [pool] [POOL-208] Support Java 1.5 Generics in version 1.x.
Date Fri, 23 Dec 2011 11:24:58 GMT
On Wed, Dec 21, 2011 at 7:32 PM, Rainer Jung <rainer.jung@kippdata.de> wrote:
> On 21.12.2011 17:41, Christian Grobmeier wrote:
>>
>> On Wed, Dec 21, 2011 at 5:19 PM, Phil Steitz<phil.steitz@gmail.com>
>>  wrote:
>>>
>>> 1.5.x ships with tomcat and is used by lots of other production
>>> applications.  We need to maintain the ability to patch it.
>>
>>
>> Tomcat 5.5 (the oldest stable version i can find) uses Java 5:
>> http://tomcat.apache.org/tomcat-5.5-doc/setup.html
>
>
> Tomcat 5.5 supports using it with Java 1.4.2 (e.g. the page you referenced
> says "If using a J2SE 1.4 JRE, the compatibility package must be downloaded
> and expanded inside the folder where Tomcat was installed.").
>
> Minimum Java versions are:
>
> TC 5.5: 1.4.2
> TC 6:   1.5.0
> TC 7:   1.6.0

Thanks Rainer, missed that.

<kidding>
Leaves me to the question if [pool] should become a Tomcat subproject
as the pool-releasecycle seems to be forget after the requirements of
tomcat.
</kidding>

Christian

>
> Regards,
>
> Rainer
>
>
>> This proposed release is binary compatible - they should not have any
>> issue to upgrade, right?
>> How long would you like to maintain the elder 1.5.x code without java 5
>> support?
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>



-- 
http://www.grobmeier.de
https://www.timeandbill.de

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message