commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [VOTE] Can the next version major version of a project require Java6? (i.e. drop Java 1.5)
Date Mon, 05 Dec 2011 18:38:46 GMT
On 5 December 2011 18:10, henrib <henrib@apache.org> wrote:
>
> sebb-2-2 wrote
>>
>> My view is that while there is still a need for software to be able to
>> run on Java 1.5, we should not insist on requiring a minimum of
>> 1.6.*unless* there is good technical reason for doing so.
>>
> But you don't consider a good (technical) reason the fact that the
> contributor can not/does not want to incur the cost of maintaining a JDK 1.5
> on its dev platforms to be able to contribute to newer versions...

No, I don't consider that a valid reason on its own.

> And no-one is stating that Java 1.5 is not in used in production somewhere;
> but IMHO, these are not the ones that will be JEXL3 users, especially since
> they have 2.1 (soon).

> Anyway and beyond the point, my advice to 1.5 users is that before trying to
> use "new" versions of libraries, migrating away from an unsupported/EOLed
> platform should be their priority.

Indeed, ideally everyone would now be using Java 6 and Windows users
should all upgrade to Windows 7 etc.

But that is a separate issue.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message