commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Brisard <celes...@apache.org>
Subject Re: [math] Strange svn conflict
Date Mon, 26 Dec 2011 18:00:48 GMT
Hi,
and many thanks for your help
>
> I have a few questions still:
>
> - Can you run 'svn diff -c r1210359' (against either mirror) and confirm
>  that that is exactly what you intended to commit?
>
Done on the EU mirror: the diff file seems OK to me.

>
> - Why would the N other files have been committed in that revision?
>  Recall that those files had no text changes and their property lists
>  were re-set to the values they already had.
>
I now recall what hapened at that time. As of 	r1206451 (see
MATH-711), interface files xxxDistribution.java and default
implementation xxxDistributionImpl.java have been merged. I did this
piece of refactoring with Eclipse, and realized later that during the
process, all SVN properties had gone. Or so it appeared in Eclipse
(since you wrote that the properties had not really gone).

So r1210359 had two purposes
1. restore the SVN properties,
2. solve MATH-715 (which resulted in "real" modifications of
PascalDistribution.java).
I hope I am not the one to blame for the current mess. I now realize
that I should have operated the refactoring outside Eclipse, using SVN
to remove the interface files, and rename the implementation files.
Also I should have used SVN as a command-line tool to check for the
presence of the SVN properties. Again, I hope I did not cause too much
damage. What can I do to try and repair that?

>
> - How to reproduce the errors you saw?  Can you show the output of `svn
>  diff` at the time of a failed commit attempt?
>
I hope this mailing list allows for attachements, in which case you
will find attached the patch I've been trying to commit for several
days now. It is a rather large patch, but I don't think that this is
the cause for our current troubles, since I've tried to commit only a
small piece and it did not work either.

Just to be sure the trouble was still occuring, I've just tried to
commit these changes, and here is what I get.

org.tigris.subversion.javahl.ClientException: Merge conflict during commit
svn: Commit failed (details follow):
svn: File or directory
'main/java/org/apache/commons/math/distribution/BinomialDistribution.java'
is out of date; try updating
svn: resource out of date; try updating

>
> - You used "SVN/1.6.15 SVNKit/1.3.5 (http://svnkit.com/) r7406" in that
>  commit.  The servers ran 1.7.0.  My client was 1.7.0 too.
>
Actually, I'm using this time
svn --version
svn, version 1.6.17 (r1128011)
   compiled Aug 25 2011, 17:51:49

Should I move to svn 1.7 ?

>
> As to the diagnosis:
>
> - The non-functional propchanges should have been collapsed and removed
>  before or during the commit.  This should happen within the FS
>  backend: the changed-paths information should not list such files with
>  'prop_mod=TRUE'.  I'm not sure if other layers should do such
>  collapsing too.
>
I'm sorry this is far out of my league... But I do hope that I've
answered your questions.

>
> Thanks,
>
> Daniel
>
Thank *you*,
Sébastien


Mime
View raw message