commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: [pool] [POOL-208] Support Java 1.5 Generics in version 1.x.
Date Wed, 21 Dec 2011 18:03:58 GMT
On 21/12/2011 16:57, Phil Steitz wrote:
> On 12/21/11 9:41 AM, Christian Grobmeier wrote:
>> On Wed, Dec 21, 2011 at 5:19 PM, Phil Steitz <phil.steitz@gmail.com> wrote:
>>> 1.5.x ships with tomcat and is used by lots of other production
>>> applications.  We need to maintain the ability to patch it.
>> Tomcat 5.5 (the oldest stable version i can find) uses Java 5:
>> http://tomcat.apache.org/tomcat-5.5-doc/setup.html
>>
>> This proposed release is binary compatible - they should not have any
>> issue to upgrade, right?
>> How long would you like to maintain the elder 1.5.x code without java 5 support?
> 
> At least until 2.0 is out and for some time after that.  Asking
> tomcat and others to upgrade twice makes no sense.  I will let Mark
> or other tc committers comment on that.

Tomcat will continue to use 1.5.x since that is what DBCP uses. When
2.0.x is ready, trunk will switch to 2.0.x and the associated DBCP
release. Depending on the results, the release branches (5.5.x, 6.0.x
and 7.0.x) may follow.

Tomcat is highly unlikely to use Pool 1.6.x

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message