commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <phil.ste...@gmail.com>
Subject Re: [pool] [POOL-208] Support Java 1.5 Generics in version 1.x.
Date Wed, 21 Dec 2011 17:01:42 GMT
On 12/21/11 9:41 AM, Christian Grobmeier wrote:
> On Wed, Dec 21, 2011 at 5:19 PM, Phil Steitz <phil.steitz@gmail.com> wrote:
>> 1.5.x ships with tomcat and is used by lots of other production
>> applications.  We need to maintain the ability to patch it.
> Tomcat 5.5 (the oldest stable version i can find) uses Java 5:
> http://tomcat.apache.org/tomcat-5.5-doc/setup.html
>
> This proposed release is binary compatible - they should not have any
> issue to upgrade, right?

Sorry, did not answer that question.  No, 1.6 would not be binary
compatible, as it will require generics.  All object factories will
have to be rewritten to use generics.

Phil
> How long would you like to maintain the elder 1.5.x code without java 5 support?
>
> Cheers
> Christian
>
>> Phil
>>> ,
>>> but that's just me. I see a non-generics pool1 as a dead end. 2.0 is
>>> great but unreleased and NOT a drop in, hence 1.6.
>>>
>>> Gary
>>>
>>> On Dec 21, 2011, at 10:51, Phil Steitz <phil.steitz@gmail.com> wrote:
>>>
>>>> As stated above, I am -1 for releasing this.  I don't think we have
>>>> resources to support three release trains in [pool].  Are you
>>>> prepared to take on bug fixing / porting, user and dev list support
>>>> for this code?  Is anyone else?
>>>>
>>>> Phil
>>>>
>>>> On 12/21/11 6:13 AM, Gary Gregory wrote:
>>>>> Hello Generics fan,
>>>>>
>>>>> Please review and continue on [POOL-208] Support Java 1.5 Generics in
>>>>> version 1.x.
>>>>>
>>>>> The code is in the POOL_1_X branch, cooking up for a 1.6 release very
soon.
>>>>>
>>>>> There are NO code changes in the main code that should affect behavior.
>>>>> I've only touched code for adding generics.
>>>>>
>>>>> As we all know, this is binary compatible with 1.5.x because of type
>>>>> erasure.
>>>>>
>>>>> I have changed some of the tests because 100% source compatibility is
not
>>>>> possible.
>>>>>
>>>>> APIs that I could not fully generify are:
>>>>>
>>>>> - org.apache.commons.pool.PoolUtils.adapt(KeyedObjectPool<Object,
V>,
>>>>> Object)
>>>>> -
>>>>> org.apache.commons.pool.PoolUtils.adapt(KeyedPoolableObjectFactory<Object,
>>>>> V>)
>>>>>
>>>>> Please dig in and help to make Pool1 with generics the best it can be
for
>>>>> 1.6.
>>>>>
>>>>> My goal is to ONLY change code for Generics.
>>>>>
>>>>> Other kind of fiddling like enhanced for-loops will make it harder to
port
>>>>> fixes to and from 1.5.x.
>>>>>
>>>>> If you like enhanced for-loops or other Java 5 features, I won't stop
you,
>>>>> but it is not my goal here.
>>>>>
>>>>> Thank you,
>>>>> Gary
>>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message