commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Bourg <ebo...@apache.org>
Subject Re: [VOTE] Can the next version major version of a project require Java6? (i.e. drop Java 1.5)
Date Wed, 07 Dec 2011 16:19:43 GMT
It's a matter or balance, if you just want to have fun you can build a 
component based on OpenJDK 8 with lots of lambda, but nobody will use it 
today. And I doubt it will attract new contributors.

If avoiding trivial things like String.isEmpty() can widen the audience, 
and thus the potential contributors, then I'm willing to develop with 
that constraint. I regret you don't seem to share this point of view, 
but I can't force you to accept it, and I won't prevent you from 
enjoying the new APIs.

Emmanuel Bourg


Mime
View raw message