commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <>
Subject [Math] Name changes in package "optimization"
Date Fri, 09 Dec 2011 13:47:27 GMT

To further rationalize the class naming in package "optimization", I propose
the following changes:
 * "RealPointValuePair" -> "PointScalarValuePair"
 * "VectorialPointValuePair" -> "PointVectorValuePair"

I wonder whether we could use the "Pair" class (in "util") as a base class
for all the "pair" classes defined in "optimization".

It would be clearer to have, for each of the above types, a single
implementation of a "Simple...Checker", to replace the two that
currently exist.
Which of "point" or "value" is to be checked could be selected using an
"enum" specified at construction.

What do you think?


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message