commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Dunning <>
Subject Re: [MATH] Re: Pivoting QR Decomposition: Take Two!
Date Wed, 05 Oct 2011 20:46:14 GMT
Actually, I think it really would be nicer for the user to have one class
that internally decides which implementation to use.  The user doesn't see
this as two classes.  They see it as a single operation (QR decomposition)
that might have a little different behavior (default slow and featureful,
optionally faster).

On Wed, Oct 5, 2011 at 1:38 PM, Gilles Sadowski <> wrote:

> From what I understand, the user will know whether he needs speed or the
> more flexible (but less efficient) alternative.
> Thus it is fine to have two implementations in separate classes: The user
> instantiates the one he needs.
> We could name them "PivotingQRDecomposition" and "FastQRDecomposition" in
> order to emphasize their expected usage.
> Any potentially duplicated code should go in a new
> "AbstractQRDecomposition"
> which the other two will inherit from.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message