commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Brisard <sebastien.bris...@m4x.org>
Subject Re: [math] Add methods opposite() and inverse() to o.a.c.m.FieldElement
Date Wed, 05 Oct 2011 03:43:00 GMT
>
> +1 to add both of these, though I would suggest one of the following
> pairs of names:
> 0) negate, invert
> 1) opposite, reciprocal
> 2) additiveInverse, multiplicativeInverse
>
> Probably 2) is clearest, but a bit long.  I am fine with any of them.
>
> Phil
>
I do think these two features might prove useful. There are
workarounds, but they tend to verbose code.
As for the options you suggest, Phil, I agree my proposition was
probably not the best. We must be careful with consistency, because
some classes already implement those methods (Complex has a method
negate()). I will look into it, and open a JIRA ticket.

Sébastien

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message