commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Brisard <>
Subject Re: [math] rename o.a.c.m.linear.SingularMatrixException to SingularLinearOperatorException
Date Sun, 02 Oct 2011 11:34:50 GMT
Right. I tend to like self-describing names also good. In french
(you've rightly spotted a non-native speaker...), an "operator" is not
necessarily linear, and I think same goes to english terminology
(could you confirm please). So a linear operator is not exactly
identical to an operator.
However, as Phil pointed out, the distinction does not really matter
when it goes to exceptions. So maybe I could replace LinearOperator
with Operator in exception names. For other classes, with more
mathematical meaning, we could keep LinearOperator, even if it makes
for very long names. Would that suit everyone?

2011/10/2 Ted Dunning <>:
> On Sat, Oct 1, 2011 at 10:58 PM, Phil Steitz <> wrote:
>> > As for shortening the name, I'm all for it. For consistency, I would
>> > do it for every class matching the pattern *LinearOperator* if you all
>> > agree. Also, I think that "linear" is as important as "operator" in
>> > "LinearOperator" (even if lilnearity might seem an obvious feature,
>> > provided all the classes we are discussing are actually located in the
>> > linear package). So what do you think of LinOp as a compromise?
>> > Something like RealLinOp instead of RealLinearOperator,
>> > NonSquareLinOpException, etc...
>> I like full words.   I don't know about "linear" vs "operator" in
>> "LinearOperator" but I think the "linear" can safely be dropped in
>> "SingularLinearOperator."
> Abbreviations don't really shorten names.  They just make them impossible
> for non-native speakers to guess.  And if abbreviations are done by
> non-native speakers, they become impossible for anybody to guess.
> +1 to avoiding abbreviations where possible.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message