commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simone Tripodi <simonetrip...@apache.org>
Subject Re: [SANDBOX] Problem with mvn deploy
Date Thu, 27 Oct 2011 11:21:20 GMT
Hi Adrian!
the best way to upload the site is running

    mvn site:site site:deploy

or better with the shortcut

    mvn site-deploy

Running `mvn site` just produces the site and with `mvn deploy` will
deploy artifacts only.
HTH and let me know how is going!
best,
Simo

http://people.apache.org/~simonetripodi/
http://simonetripodi.livejournal.com/
http://twitter.com/simonetripodi
http://www.99soft.org/



On Thu, Oct 27, 2011 at 1:08 PM, Adrian Crum
<adrian.crum@sandglass-software.com> wrote:
> One last question: I ran mvn site and mvn deploy - will those commands
> update the website?
>
> -Adrian
>
> On 10/27/2011 12:05 PM, Simone Tripodi wrote:
>>
>> Cool, nice to hear that!!!
>> All the best,
>> Simo
>>
>> http://people.apache.org/~simonetripodi/
>> http://simonetripodi.livejournal.com/
>> http://twitter.com/simonetripodi
>> http://www.99soft.org/
>>
>>
>>
>> On Thu, Oct 27, 2011 at 1:00 PM, Adrian Crum
>> <adrian.crum@sandglass-software.com>  wrote:
>>>
>>> That solved the problem - thanks!
>>>
>>> -Adrian
>>>
>>> On 10/27/2011 11:54 AM, Simone Tripodi wrote:
>>>>
>>>> ouch, that's such a shame ;(
>>>> poor-man question: did you add the servers in the settings.xml file?
>>>>
>>>> <!-- To publish a snapshot -->
>>>> <server>
>>>>   <id>apache.snapshots.https</id>
>>>>   <username><!-- ASF login name --></username>
>>>>   <password>{encryptedpassword}</password>
>>>> </server>
>>>> <!-- To publish a release -->
>>>> <server>
>>>>   <id>apache.releases.https</id>
>>>>   <username><!-- ASF login name --></username>
>>>>   <password>{encryptedpassword}</password>
>>>> </server>
>>>>
>>>> http://people.apache.org/~simonetripodi/
>>>> http://simonetripodi.livejournal.com/
>>>> http://twitter.com/simonetripodi
>>>> http://www.99soft.org/
>>>>
>>>>
>>>>
>>>> On Thu, Oct 27, 2011 at 12:49 PM, Adrian Crum
>>>> <adrian.crum@sandglass-software.com>    wrote:
>>>>>
>>>>> Thanks Simone! I tried the encryption again - same error.
>>>>>
>>>>> -Adrian
>>>>>
>>>>> On 10/27/2011 11:36 AM, Simone Tripodi wrote:
>>>>>>
>>>>>> Hi Adrian!
>>>>>> for what I can see looks like you maybe misconfigured the credentials
>>>>>> to access to apache.snapshots.https server in settings.xml because
>>>>>> Nexus doesn't authorize you :(
>>>>>> I suggest you checking the `Preparations for using Nexus` again and
>>>>>> pay attention on encrypting your ASF password.
>>>>>> HTH, let me know if you need more info!
>>>>>> Simo
>>>>>>
>>>>>> http://people.apache.org/~simonetripodi/
>>>>>> http://simonetripodi.livejournal.com/
>>>>>> http://twitter.com/simonetripodi
>>>>>> http://www.99soft.org/
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Thu, Oct 27, 2011 at 12:28 PM, Adrian Crum
>>>>>> <adrian.crum@sandglass-software.com>      wrote:
>>>>>>>
>>>>>>> Thanks Simone! I created the settings.xml file and
>>>>>>> security-settings.xml
>>>>>>> file in my .m2 folder as described on the websites, but I still
get
>>>>>>> the
>>>>>>> same
>>>>>>> error. Are there any configuration xml file examples somewhere
that I
>>>>>>> can
>>>>>>> copy and modify for use with Commons?
>>>>>>>
>>>>>>> -Adrian
>>>>>>>
>>>>>>> On 10/27/2011 7:23 AM, Simone Tripodi wrote:
>>>>>>>>
>>>>>>>> Hi Adrian!
>>>>>>>> for what I can see you just need some missing config in your
>>>>>>>> settings.xml, take a look ate the wiki page[1] how to configure
>>>>>>>> Maven
>>>>>>>> to deploy artifacts on Nexus - it is valid for SNAPSHOTS
as well.
>>>>>>>> HTH, please let me know if you need more help!
>>>>>>>> All the best,
>>>>>>>> Simo
>>>>>>>>
>>>>>>>> [1] http://wiki.apache.org/commons/UsingNexus
>>>>>>>>
>>>>>>>> http://people.apache.org/~simonetripodi/
>>>>>>>> http://simonetripodi.livejournal.com/
>>>>>>>> http://twitter.com/simonetripodi
>>>>>>>> http://www.99soft.org/
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> On Thu, Oct 27, 2011 at 5:33 AM, Adrian Crum
>>>>>>>> <adrian.crum@sandglass-software.com>        wrote:
>>>>>>>>>
>>>>>>>>> When I try to deploy the Commons Sandbox Convert project,
I get the
>>>>>>>>> following error:
>>>>>>>>>
>>>>>>>>> [INFO] [deploy:deploy {execution: default-deploy}]
>>>>>>>>> [INFO] Retrieving previous build number from apache.snapshots.https
>>>>>>>>> [INFO] repository metadata for: 'snapshot
>>>>>>>>> org.apache.commons:commons-convert:1.0
>>>>>>>>> -SNAPSHOT' could not be found on repository:
>>>>>>>>> apache.snapshots.https,
>>>>>>>>> so
>>>>>>>>> will
>>>>>>>>> be
>>>>>>>>> created
>>>>>>>>> Uploading:
>>>>>>>>>
>>>>>>>>> https://repository.apache.org/content/repositories/snapshots/org/apac
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> he/commons/commons-convert/1.0-SNAPSHOT/commons-convert-1.0-20111027.032634-1.jar
>>>>>>>>> [INFO]
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> ------------------------------------------------------------------------
>>>>>>>>> [ERROR] BUILD ERROR
>>>>>>>>> [INFO]
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> ------------------------------------------------------------------------
>>>>>>>>> [INFO] Error deploying artifact: Failed to transfer file:
>>>>>>>>> https://repository.apa
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> che.org/content/repositories/snapshots/org/apache/commons/commons-convert/1.0-SN
>>>>>>>>> APSHOT/commons-convert-1.0-20111027.032634-1.jar. Return
code is:
>>>>>>>>> 401
>>>>>>>>>
>>>>>>>>> Any help would be appreciated.
>>>>>>>>>
>>>>>>>>> -Adrian
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> ---------------------------------------------------------------------
>>>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>>> ---------------------------------------------------------------------
>>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>>>>
>>>>>>> ---------------------------------------------------------------------
>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>>>
>>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>
>>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>
>>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message