commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <phil.ste...@gmail.com>
Subject Re: [math] Add methods opposite() and inverse() to o.a.c.m.FieldElement
Date Fri, 07 Oct 2011 14:34:26 GMT




On Oct 7, 2011, at 6:07 AM, Sébastien Brisard <sebastien.brisard@m4x.org> wrote:

>> 
>> +1 to add both of these, though I would suggest one of the following
>> pairs of names:
>> 0) negate, invert
>> 1) opposite, reciprocal
>> 2) additiveInverse, multiplicativeInverse
>> 
>> Probably 2) is clearest, but a bit long.  I am fine with any of them.
>> 
>> Phil
>> 
> Hi,
> I've created MATH-686 which relates to this proposal. However looking
> at what's already implemented in the CM library, I found that the best
> (unsatisfactory) option would be negate()/reciprocal() -- see the
> ticket. Native english speakers will probably not like that! Are we
> really that unhappy with this?

Not worth a long argument, but the reciprocal of a fraction is not exactly the same concept
as multiplicative inverse in a field.  I would be happier about living with that inconsistency
than adding another noun/verb inconsistency in the same class.

Phil

> Sébastien
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message