commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luc Maisonobe <Luc.Maison...@free.fr>
Subject Re: [Math] Naming confusion
Date Sat, 29 Oct 2011 07:10:12 GMT
Le 28/10/2011 23:30, Gilles Sadowski a écrit :
> Hello.
> 
> I think that something is not quite right in those class names:
>   UnivariateMatrixFunction
>   UnivariateRealFunction
>   UnivariateVectorialFunction
> 
> To be consistent, we should either
>  1. indicate the "grouping" and "number" type everywhere:
>        UnivariateRealMatrixFunction
>        UnivariateRealFunction
>        UnivariateRealVectorialFunction 
>  2. assume that the "number" type is "Real", and drop it everywhere:
>        UnivariateMatrixFunction
>        UnivariateFunction
>        UnivariateVectorialFunction 
>  3. assume that the "number" type is "Real", drop it everywhere, and
>     indicate the "grouping" explicitly everywhere:
>        UnivariateMatrixFunction
>        UnivariateScalarFunction
>        UnivariateVectorialFunction 
> 
> The same goes for "Multivariate...", "Differentiable...", and the optimizers
> naming.
> 
> I'd say that option 2 is the least disruptive, and most practical as
>   UnivariateFunction
> is more common (and shorter) than
>   UnivariateScalarFunction

You're right, lets go to a more consistent scheme. Option 2 is fair.

Luc

> 
> 
> 
> Regards,
> Gilles
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message