commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <phil.ste...@gmail.com>
Subject Re: [Math] Problem with svn
Date Wed, 26 Oct 2011 22:43:27 GMT
On 10/26/11 2:51 PM, Gilles Sadowski wrote:
>>>>>> Trying to commit a few files, I get this error:
>>>>>> ---CUT---
>>>>>> Sending
>>>>>> src/main/java/org/apache/commons/math/analysis/integration/UnivariateRealIntegratorImpl.java
>>>>>> Sending src/main/java/org/apache/commons/math/geometry/euclidean/threed/Line.java
>>>>>> Sending src/main/java/org/apache/commons/math/linear/EigenDecomposition.java
>>>>>> svn: Commit failed (details follow):
>>>>>> svn: File or directory 'main/java/org/apache/commons/math/linear/EigenDecomposition.java'
is out of date; try updating
>>>>>> svn: resource out of date; try updating
>>>>>> svn: Your commit message was left in a temporary file:
>>>>>> svn:    '/home/gilles/devel/SVN/commons-math/trunk/svn-commit.2.tmp'
>>>>>> ---CUT---
>>>>>>
>>>>>> I've been trying more than 15 times, with the same error.
>>>>>> Obviously, I did "svn up" (almost as many times).
>>>>>> As suggested on the web, I removed all files name "all-wcprops" in
the ".svn"
>>>>>> directories.
>>>>>> I tried from a different machine.
>>>>>> I also deleted the whole working copy and did "svn co".
>>>>>> I upgrade "subversion" to version 1.6.17.
>>>>>> All to no avail.
>>>>>>
>>>>>> Do you have an idea about possible causes and remedies?
>>>>>> I can also send a tar ball with the modified files. Could someone
try to
>>>>>> commit them from his side? Or have a look at the files?
>>>>> Interesting.  Usually means what the message indicates - the working
>>>>> copy is out of date.
>>>> Cannot be out of date a few seconds after "svn up"...
>>>> In my experience, subversion messages do not mean what they say, and the
>>>> suggested solution does not work. :-/
>>>> [Also, the fact that people got a similar issue resolved by deleting some
of
>>>> subversion's files is not conforting.]
>>>>
>>>>> Try doing "svn cleanup" from the checkout.
>>>> I forgot to mention, but I did that too.
>>>>
>>>>> If
>>>>> that doesn't work, upload a tarball to your home directory and I
>>>>> will grab it and see if I can figure out what is going on.
>>>> Thanks, it's in directory "/home/erans".
>>>>
>>>>> After
>>>>> you did a clean checkout, how did you recreate the changed files?
>>>> I extracted them from the tar file.
>>> I will grab the files and have a look.  It could be that the problem
>>> has to do with svn props, which were changed in the last commit on
>>> those files.  When you overwrite them with "old" versions, the line
>>> endings get changed and that may be causing the problem.  Could be
>>> you will have to manually re-apply whatever changes you are making
>>> to those files instead of just overwriting.
>>>>> Does svn diff look right after the changes?
>>>> Yes, it shows the changes which I'm trying to commit (MATH-689):
>>>> Substitution of "MathUtils." with "Precision.".
>>>>
>>>> The commit stops at the third file: "EigenDecomposition.java". When I tried
>>>> to skip that file, it stopped at "SingularValueDecomposition.java".
>>> Let me have a look...
>> Looks like your changed files were from the 9/22 revision of the
>> linear package files.  I suspect that the props change may be the
>> problem.  I am not an svn expert, maybe someone else knows more. 
>> But I would try this:
>>
>> 0) Start with clean checkout
>> 1) do your untarring to overwrite the files with changed versions
>> 2) create a patch using svn diff > temp.patch
>> 3) revert or do a new clean checkout
>> 4) apply the patch you made in 2
> That looked like a good plan. But it didn't work. :-{
> I tried this route:
>  $ rm -rf trunk
>  $ svn co ...
>  $ tar xzf cm.tar.gz
>  $ svn diff
>  $ rm -rf trunk
>  $ svn co ...
>  $ patch -pO < diff
>  $ svn commit
> and it fails...

If nobody responds in the next few hours with a better idea, i will
try the commit based on the tar on my end.  What should be the
commit message?

Phil
>
>
> Gilles
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message