commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <phil.ste...@gmail.com>
Subject Re: [Math] Problem with svn
Date Wed, 26 Oct 2011 15:02:58 GMT
On 10/26/11 7:44 AM, Gilles Sadowski wrote:
> Hi.
>
> Trying to commit a few files, I get this error:
> ---CUT---
> Sending
> src/main/java/org/apache/commons/math/analysis/integration/UnivariateRealIntegratorImpl.java
> Sending src/main/java/org/apache/commons/math/geometry/euclidean/threed/Line.java
> Sending src/main/java/org/apache/commons/math/linear/EigenDecomposition.java
> svn: Commit failed (details follow):
> svn: File or directory 'main/java/org/apache/commons/math/linear/EigenDecomposition.java'
is out of date; try updating
> svn: resource out of date; try updating
> svn: Your commit message was left in a temporary file:
> svn:    '/home/gilles/devel/SVN/commons-math/trunk/svn-commit.2.tmp'
> ---CUT---
>
> I've been trying more than 15 times, with the same error.
> Obviously, I did "svn up" (almost as many times).
> As suggested on the web, I removed all files name "all-wcprops" in the ".svn"
> directories.
> I tried from a different machine.
> I also deleted the whole working copy and did "svn co".
> I upgrade "subversion" to version 1.6.17.
> All to no avail.
>
> Do you have an idea about possible causes and remedies?
> I can also send a tar ball with the modified files. Could someone try to
> commit them from his side? Or have a look at the files?

Interesting.  Usually means what the message indicates - the working
copy is out of date.  Try doing "svn cleanup" from the checkout.  If
that doesn't work, upload a tarball to your home directory and I
will grab it and see if I can figure out what is going on.  After
you did a clean checkout, how did you recreate the changed files?  
Does svn diff look right after the changes?

Phil
>
>
> Thanks,
> Gilles
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message