commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <gil...@harfang.homelinux.org>
Subject [Math] Naming confusion
Date Fri, 28 Oct 2011 21:30:04 GMT
Hello.

I think that something is not quite right in those class names:
  UnivariateMatrixFunction
  UnivariateRealFunction
  UnivariateVectorialFunction

To be consistent, we should either
 1. indicate the "grouping" and "number" type everywhere:
       UnivariateRealMatrixFunction
       UnivariateRealFunction
       UnivariateRealVectorialFunction 
 2. assume that the "number" type is "Real", and drop it everywhere:
       UnivariateMatrixFunction
       UnivariateFunction
       UnivariateVectorialFunction 
 3. assume that the "number" type is "Real", drop it everywhere, and
    indicate the "grouping" explicitly everywhere:
       UnivariateMatrixFunction
       UnivariateScalarFunction
       UnivariateVectorialFunction 

The same goes for "Multivariate...", "Differentiable...", and the optimizers
naming.

I'd say that option 2 is the least disruptive, and most practical as
  UnivariateFunction
is more common (and shorter) than
  UnivariateScalarFunction



Regards,
Gilles

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message