commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jochen Wiedmann <>
Subject Re: [math] RealVector.toArray() vs. RealVector.getData()
Date Wed, 07 Sep 2011 06:17:24 GMT
2011/9/7 S├ębastien Brisard <>:
> Hi,
> as noted in MATH-653, these two methods are redundant, and one should
> go. Pros and cons are
> * toArray() is fairly classical in the Java world
> * but getData() is consistent with ArrayRealVector.getDataRef().
> Personnaly, my preference goes to keeping toArray(). In order to
> maintain consistency, should ArrayRealVector.getDataRef() be renamed
> getArrayRef() ?

Another Con; INcompatible change, which should be avoided, if
possible. Redundancy is not a compelling reason for such changes.

Capitalism is the astounding belief that the most wickedest of men
will do the most wickedest of things for the greatest good of

John Maynard Keynes (

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message