commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simone Tripodi <simonetrip...@apache.org>
Subject skip the bundle-plugin
Date Mon, 12 Sep 2011 09:23:38 GMT
Hi all guys,
while trying to fix CHAIN-57, I switched to JDK5 to run tests, and
accidentally found an error because looks like the maven-bundle-plugin
requires JDK6 to run.
I raw the plugin documentation to see if there's an option to skip
plugin execution, but didn't figure out how to.
Do you have any suggestion?
TIA, all the best!
Simo


$ mvn --version
Apache Maven 3.0.3 (r1075438; 2011-02-28 18:31:09+0100)
Maven home: /Applications/apache-maven-3.0.3
Java version: 1.5.0_30, vendor: Apple Inc.
Java home: /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home
Default locale: en_US, platform encoding: MacRoman
OS name: "mac os x", version: "10.7.1", arch: "i386", family: "unix"

//------------------------------------------------------------------------------------------------------------------------

$ mvn clean test

[ERROR] Failed to execute goal
org.apache.felix:maven-bundle-plugin:2.3.5:manifest (bundle-manifest)
on project commons-chain: Execution bundle-manifest of goal
org.apache.felix:maven-bundle-plugin:2.3.5:manifest failed: An API
incompatibility was encountered while executing
org.apache.felix:maven-bundle-plugin:2.3.5:manifest:
java.lang.NoSuchMethodError:
java.lang.String.getBytes(Ljava/nio/charset/Charset;)[B

http://people.apache.org/~simonetripodi/
http://www.99soft.org/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message