commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simone Tripodi <simonetrip...@apache.org>
Subject Re: skip the bundle-plugin
Date Mon, 12 Sep 2011 13:57:08 GMT
Hi again Seb,
just to confirm that your fix works!!!
Thanks a lot!
Simo

http://people.apache.org/~simonetripodi/
http://www.99soft.org/



On Mon, Sep 12, 2011 at 3:52 PM, Simone Tripodi
<simonetripodi@apache.org> wrote:
> Thanks to you!
> I just raw your commits, I'm going to test it so I can provide more help!
> Simo
>
> http://people.apache.org/~simonetripodi/
> http://www.99soft.org/
>
>
>
> On Mon, Sep 12, 2011 at 3:40 PM, sebb <sebbaz@gmail.com> wrote:
>> On 12 September 2011 13:46, Simone Tripodi <simonetripodi@apache.org> wrote:
>>> Apologize,
>>> I was still using the 22-SNAPSHOT to test the build number!
>>> I am now able to reproduce the issue, thank you in advance for your help!
>>
>> Thanks for raising the bundle issue; I've hopefully now fixed CP 22 so
>> it works with both Java 1.5 and 1.6.
>>
>>> Simo
>>>
>>> http://people.apache.org/~simonetripodi/
>>> http://www.99soft.org/
>>>
>>>
>>>
>>> On Mon, Sep 12, 2011 at 2:27 PM, sebb <sebbaz@gmail.com> wrote:
>>>> On 12 September 2011 13:09, Simone Tripodi <simonetripodi@apache.org>
wrote:
>>>>> Hi Seb,
>>>>> we are using the commons-parent:21, anyway the issues seems affecting
>>>>
>>>> Are you sure? I only get the problem when using 22-SNAPSHOT, which has
>>>> updated to bundle 2.3.5.
>>>>
>>>> CP 21 uses bundle 1.4.3.
>>>>
>>>>> compiler problems rather than the java language itself (with Java6
>>>>> indeed it does work), take a look at CHAIN-57[1], you maybe already
>>>>> know the solution :P
>>>>
>>>> I'll try and have a look later.
>>>>
>>>>> Many thanks in advance, all the best!
>>>>> Simo
>>>>>
>>>>> [1] https://issues.apache.org/jira/browse/CHAIN-57
>>>>>
>>>>> http://people.apache.org/~simonetripodi/
>>>>> http://www.99soft.org/
>>>>>
>>>>>
>>>>>
>>>>> On Mon, Sep 12, 2011 at 1:41 PM, sebb <sebbaz@gmail.com> wrote:
>>>>>> On 12 September 2011 10:23, Simone Tripodi <simonetripodi@apache.org>
wrote:
>>>>>>> Hi all guys,
>>>>>>> while trying to fix CHAIN-57, I switched to JDK5 to run tests,
and
>>>>>>> accidentally found an error because looks like the maven-bundle-plugin
>>>>>>> requires JDK6 to run.
>>>>>>> I raw the plugin documentation to see if there's an option to
skip
>>>>>>> plugin execution, but didn't figure out how to.
>>>>>>> Do you have any suggestion?
>>>>>>
>>>>>> Which Commons Parent are you using?
>>>>>>
>>>>>> We obviously need to fix things so Maven can run with Java 5, but
in
>>>>>> the meantime you can run Maven with Java 6, but still compile/test
>>>>>> with Java 5.
>>>>>> See:
>>>>>>
>>>>>> http://commons.apache.org/commons-parent-pom.html#Testing_with_different_Java_versions
>>>>>>
>>>>>>> TIA, all the best!
>>>>>>> Simo
>>>>>>>
>>>>>>>
>>>>>>> $ mvn --version
>>>>>>> Apache Maven 3.0.3 (r1075438; 2011-02-28 18:31:09+0100)
>>>>>>> Maven home: /Applications/apache-maven-3.0.3
>>>>>>> Java version: 1.5.0_30, vendor: Apple Inc.
>>>>>>> Java home: /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home
>>>>>>> Default locale: en_US, platform encoding: MacRoman
>>>>>>> OS name: "mac os x", version: "10.7.1", arch: "i386", family:
"unix"
>>>>>>>
>>>>>>> //------------------------------------------------------------------------------------------------------------------------
>>>>>>>
>>>>>>> $ mvn clean test
>>>>>>>
>>>>>>> [ERROR] Failed to execute goal
>>>>>>> org.apache.felix:maven-bundle-plugin:2.3.5:manifest (bundle-manifest)
>>>>>>> on project commons-chain: Execution bundle-manifest of goal
>>>>>>> org.apache.felix:maven-bundle-plugin:2.3.5:manifest failed: An
API
>>>>>>> incompatibility was encountered while executing
>>>>>>> org.apache.felix:maven-bundle-plugin:2.3.5:manifest:
>>>>>>> java.lang.NoSuchMethodError:
>>>>>>> java.lang.String.getBytes(Ljava/nio/charset/Charset;)[B
>>>>>>>
>>>>>>> http://people.apache.org/~simonetripodi/
>>>>>>> http://www.99soft.org/
>>>>>>>
>>>>>>> ---------------------------------------------------------------------
>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>>>
>>>>>>>
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>>
>>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>
>>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>
>>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message