commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <phil.ste...@gmail.com>
Subject Re: [math] Monitoring iterative algorithms
Date Fri, 09 Sep 2011 20:03:22 GMT
On 9/9/11 12:13 PM, S├ębastien Brisard wrote:
> Hi,
> I was wondering if anyone of you had the chance to look at the new
> piece of code submitted (JIRA MATH-655).
> Thanks for your comments!

Sorry to be slow on this.  I would say go ahead and commit the last
patch and we can talk about patching from there.  I don't have any
significant comments.  Only

0) maybe incrementIterationCount in the manager should be called
startIteration
1) I guess TooManyEvaluations is the only thing left to throw, but
MaxIterationsExceeded or even something new like IllegalIteration
might make sense here (bad name, but once we introduce
StoppingCriteria, something like that will make sense).
2) It is tempting to go ahead and define the StoppingCondition and
add it as a constructor parameter for the manager.
3) Incrementor is a little crippled not exposing a constructor with
the max  - could be we should add that and use it in the manager.
4) Similarly Incrementor could expose a hasMore() or somesuch, which
would provide a meaningful default for shouldStop and also provide
the basis for an iterationsExhausted event.
5) It may be extra noise and I know we need to be careful with this,
but a fireIterationStarted source might be useful in some contexts.

Phil
> S├ębastien
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message