commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [parent] plugin updates
Date Thu, 25 Aug 2011 01:45:42 GMT
On 25 August 2011 02:12, Gary Gregory <garydgregory@gmail.com> wrote:
> Hi All:
>
> According to their respective sites, the following plugins can be updated
> while keeping builds running on Maven 2.0.x and JDK 1.4.

(See below - I don't think that restriction is necessary)

> maven-antrun-plugin 1.5 to 1.6 (Maven 2.0.6, JDK 1.4)
> maven-clean-plugin 2.4 to 2.4.1 (Maven 2.0.6, JDK 1.4)
> maven-deploy-plugin 2.5 to 2.6 (Maven 2.0.6, JDK 1.4)
> maven-gpg-plugin 1.2 to 1.3 (Maven 2.0.6, JDK 1.4)
> maven-install-plugin 2.3 to 2.3.1 (Maven 2.0.6, JDK 1.4)
> maven-resources-plugin 2.4.1 to 2.5 (Maven 2.0.6, JDK 1.4)
> maven-source-plugin 2.1.1 to 2.1.2 (Maven 2.0.6, JDK 1.4)
> maven-jxr-plugin 2.1 to 2.3 (Maven 2.0.9, JDK 1.4)
> maven-surefire-plugin 2.8.1 to 2.9 (Maven 2.0.9, JDK 1.4)
>
> Make some noise if you are not OK with updating any of these.
>
> The following should not be updated yet because they require Java 5.
>
> maven-release-plugin 2.0 to 2.2.1 (Maven 2.0.9, JDK 1.5)
> maven-project-info-reports-plugin 2.3.1 to 2.4 (Maven 2.2.0, JDK 1.5)
> maven-javadoc-plugin 2.7 to 2.8 (Maven 2.0.9, JDK 1.5)

As far as I know, most people use Maven 2.2.1 which requires Java 1.5.

That is partly why we added the java-1.x profiles.
They allow Java 1.5 or later to be used to run Maven, but still allow
the use of a different version of Java for compile and test.

So I see no reason why we should not update the last 3 plugins as well.

> Thank you,
> Gary
> ---
>
> http://garygregory.wordpress.com/
> http://garygregory.com/
> http://people.apache.org/~ggregory/
> http://twitter.com/GaryGregory
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message