commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Dunning <ted.dunn...@gmail.com>
Subject Re: [math] RealMatrix.set(double)
Date Fri, 26 Aug 2011 06:19:50 GMT
Well, in turn, I have flipped a bit on the visitor.  I just think that the
name of the method that accepts the visitor should be the same so that users
think of it as the same thing.  Functions are good, but giving a tiny  bit
more information to the function is also a great idea.  It will still
effectively be a visitor, but users won't have to know that is what it is.

On Thu, Aug 25, 2011 at 10:45 PM, Phil Steitz <phil.steitz@gmail.com> wrote:

> Thanks, Ted.  That does look very flexible and approachable too.  I
> am sorry to flip-flop on this issue; but I am now thinking it might
> actually be better to replace the visitor setup that we have with
> something like the above, partly due to Greg's comments as well on
> the limitations of the current code.  I encourage others to have a
> look at the Mahout code and consider the pros and cons of
> refactoring.  I don't think the visitor machinery is really used
> internally, so refactoring would not be cataclysmic.  Now is the
> time to do it if we want to go to a model based more on views and
> the functional approach.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message