commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Petrelli <antonio.petre...@gmail.com>
Subject Re: [logging] logging vs slf4j
Date Wed, 03 Aug 2011 18:16:21 GMT
Hi Ceki

2011/8/3 Ceki Gülcü <ceki@qos.ch>

> Antonio Petrelli wrote:
> On the other hand, the version of slf4j binding that you select at
> runtime needs to match the slf4j-api. For example, if you have
> slf4j-api-1.6.1.jar on your classpath and you wish to use log4j, then
> you need slf4j-log4j12-1.6.1.jar on your class path,
> slf4j-log4j12-1.4.3.jar will not work.
>

I think this is the JBoss Portal case, in which slf4j 1.4.3 (both api and
binding) is installed and all the portlets are forced to use it.
So I think it is a problem with JBoss and JBoss Portal, or even portlet
specification itself that are flawed.
However the main difference between SLF4J and JCL is that JCL is stuck to
1.1.1 so there is less opportunity for a version mismatch :-D
Thanks, I will reply to my own email in the Commons ML about it.

Antonio

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message