commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <phil.ste...@gmail.com>
Subject Re: [VOTE] Release Commons Configuration 1.7 based on RC1
Date Sun, 28 Aug 2011 17:45:46 GMT
On 8/28/11 3:51 AM, Oliver Heger wrote:
> This is a vote to release Apache Commons Configuration 1.7 based
> on the first RC.
>
> Tag:
> http://svn.apache.org/repos/asf/commons/proper/configuration/tags/CONFIGURATION_1_7RC1/
>
> Distributions: http://people.apache.org/~oheger/configuration-1.7rc1/
>
> Maven artifacts:
> http://people.apache.org/~oheger/configuration-1.7rc1/maven/
>
> Site: http://people.apache.org/~oheger/configuration-1.7rc1/site/
>
> [ ] +1 release it
> [ ] +0 go ahead I don't care
> [ ] -1 no, do not release it because...
>
> Vote will remain open for 72 hours.

The release notes (which are very nice, btw) say that 1.3 compat has
been dropped, but the site says 1.4 is still supported.  I get the
following compile error when I try to compile using 1.4 (under Ant)
[javac] bad class file:
/home/psteitz/.m2/repository/org/apache/commons/commons-vfs2/2.0/commons-vfs2-2.0.jar(org/apache/commons/vfs2/FileObject.class)
    [javac] class file has wrong version 49.0, should be 48.0
    [javac] Please remove or make sure it appears in the correct
subdirectory of the classpath.
    [javac] import org.apache.commons.vfs2.FileObject;

The Ant build did not work for me out of the box either.  It should
probably be either replaced with a working Ant build or removed.  It
tries to pull release versions of dependencies from the apache
snapshots repo and it also looks for JUNIT in ANT_HOME.  To get it
to work, I removed the unless key on the test goal, and relied on
the fact that all deps were already in my local repo.

Other than these issues, the release looks great.  Could be the
first issue is OK for runtime use, as long as whoever is using the
component under 1.4 pulls in a compatible VFS if this is used.  But
it looks like VFS is a required (not test only) dependency, so
unless I am missing something, this means you can't build from
source under 1.4.  Does the maven 1.4 profile work here?  Sorry I
did not test that.

Phil


>
> Oliver
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message