commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <>
Subject Re: [Math] New method: "addToEntry" in "RealVector"
Date Wed, 17 Aug 2011 22:28:07 GMT
On 8/17/11 3:14 PM, Gilles Sadowski wrote:
> Hi.
> 1. Is it OK to add an "addToEntry" method to "RealVector"? [There is one in
>    "AbstractRealMatrix".] Do I need to open a JIRA issue for this?
> 2. Are we going to remove the "RealVector" interface in favour of keeping
>    only an abstract concrete class ("AbstractRealVector") at the top of the
>    hierarchy? [The class could be renamed "RealVector".]

+1 to go ahead and remove the interface and reclaim the name.  This
is a little scary, but now is the time to do these things.  I am
thinking about doing the same thing in lots of interface/impl splits
where we have only one impl.  If anyone is opposed to this, please
speak up now.  I think each such change should be tracked in a JIRA
and changes.xml so we have a record of the decision and the
associated commits.

> Regards,
> Gilles
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message