commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <gil...@harfang.homelinux.org>
Subject Re: [math] RealMatrix.set(double)
Date Wed, 24 Aug 2011 09:54:30 GMT
Hi.

On Wed, Aug 24, 2011 at 02:12:33AM +0200, S├ębastien Brisard wrote:
> I think this is already implemented as
> walkInXXXOrder(RealMatrixChangingVisitor). I thought it would be handy
> (and consistent with RealVector) to have this very method, but it's
> true a RealMatrixChangingVisitorFactory would do very nicely.
> S├ębastien

This discussion should really be connected to issue
  https://issues.apache.org/jira/browse/MATH-643
and to the recent thread with subject:
  New method: "addToEntry" in "RealVector"
and to the thread started some time ago by Greg about simplifying the
"RealMatrix" interface.

There are several points:
 * Consistency in naming and make explicit the rationale for choosing one or
   another naming scheme
 * Consistency of operations (and naming) between "RealVector" and
   "RealMatrix"
 * Which methods should be added
 * Which methods should be removed
 * What API to adopt to let user "create" entry-changing functions

I'd suggest to create a JIRA ticket that would include a general overview of
all those related changes.


Regards,
Gilles

> [...]

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message