commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <flame...@gmail.com>
Subject Re: [LANG] Commons Lang 3.0
Date Thu, 28 Jul 2011 22:24:22 GMT
Go for it :)

On Wed, Jul 27, 2011 at 8:46 AM, Paul Benedict <pbenedict@apache.org> wrote:
> You know, it would probably be nice for our end users to note what
> this email contained for our home page:
>
> 1) A clear explanation that Commons Lang 3 and 2/1 can co-exist side
> by side and that upgrading to 3 doesn't mean you won't still need
> previous versions.
> 2) What we know other Apache Commons depend on 2.x
>
> Paul
>
> On Wed, Jul 27, 2011 at 10:41 AM, Matt Benson <gudnabrsam@gmail.com> wrote:
>> Or maybe I won't hit [flatfile], since I see you've just done so.  ;)  Thanks!
>>
>> Matt
>>
>> On Wed, Jul 27, 2011 at 10:40 AM, Matt Benson <gudnabrsam@gmail.com> wrote:
>>> Good point.  I'll go ahead and update [flatfile].  IIRC the proxy 2
>>> branch already uses [lang] 3; I'll update that to use the release.
>>>
>>> Matt
>>>
>>> On Wed, Jul 27, 2011 at 10:32 AM, Henri Yandell <flamefew@gmail.com> wrote:
>>>> For the record, and so we can consider what needs a release, the
>>>> following components depend on Lang:
>>>>
>>>> * Chain
>>>> * Configuration
>>>> * JCS
>>>> * Proxy
>>>>
>>>> and in the Sandbox:
>>>>
>>>> * Flatfile
>>>> * Pipeline
>>>>
>>>> Hen
>>>>
>>>> On Wed, Jul 27, 2011 at 6:13 AM, Paul Benedict <pbenedict@apache.org>
wrote:
>>>>> Yes. The reason the package name was changed was so that 1.x-2.x and
>>>>> 3.0 can coexist together in an application. Since Commons
>>>>> Configuration relies on a previous version, as Stephen said, you will
>>>>> need both dependencies.
>>>>>
>>>>> On Wed, Jul 27, 2011 at 7:53 AM, Stephen Colebourne
>>>>> <scolebourne@joda.org> wrote:
>>>>>> You will need both versions of commons-lang, the new and the old.
>>>>>> Stephen
>>>>>>
>>>>>> On 27 July 2011 11:17, Rohan Kadam <rohanka@cybage.com> wrote:
>>>>>>> Hi All,
>>>>>>>
>>>>>>> We have upgraded our common lang jar to 3.0 version. We have
replaced package name "lang" to "lang3". But since it has already been mentioned on apache
website that Common Lang 3.0 is not backward compatible, we are facing some compilation issues.
>>>>>>>
>>>>>>> After replacing Apache Commons Lang 2.1 with Apache Commons Lang
3.0 we get some compilation errors since the class org.apache.commons.lang.exception.NestableException
is being referred internally in the class files of  org.apache.commons.configuration.ConfigurationException.
>>>>>>>
>>>>>>> To summarize the common lang jar to 3.0 version is not compatible
with common configuration jar latest version.
>>>>>>>
>>>>>>> Please suggest.
>>>>>>>
>>>>>>> Thanks.
>>>>>>>
>>>>>>> "Legal Disclaimer: This electronic message and all contents contain
information from Cybage Software Private Limited which may be privileged, confidential, or
otherwise protected from disclosure. The information is intended to be for the addressee(s)
only. If you are not an addressee, any disclosure, copy, distribution, or use of the contents
of this message is strictly prohibited. If you have received this electronic message in error
please notify the sender by reply e-mail to and destroy the original message and all copies.
Cybage has taken every reasonable precaution to minimize the risk of malicious content in
the mail, but is not liable for any damage you may sustain as a result of any malicious content
in this e-mail. You should carry out your own malicious content checks before opening the
e-mail or attachment."
>>>>>>> www.cybage.com
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> ---------------------------------------------------------------------
>>>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>>>
>>>>>>>
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>>
>>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>
>>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>
>>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message