commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Grobmeier <grobme...@gmail.com>
Subject Re: [vfs] mvn3 eclipse fails
Date Tue, 26 Jul 2011 12:03:15 GMT
OK, then the mvn eclipse plugin 2.8 will fail when building it because
it does not support ".." path. Should we nail down the mvn-eclipse
version to 2.7 in the pom? We have something similar for the idea
plugin in the parent pom.

The other question is, if it is really a good idea to depend a sub
project to a top project (just because of two files). Wouldn't it be
better to copy LICENSE/NOTICE to core, examples and sandbox too?



On Sun, Jul 24, 2011 at 9:20 PM, Ralph Goers <ralph.goers@dslextreme.com> wrote:
> Also, the change was incorrect as it was using basedir to locate the NOTICE and LICENSE
files. basedir will refer to the core subproject, not the project root, which is where those
files are located.
>
> On Jul 24, 2011, at 12:14 PM, Ralph Goers wrote:
>
>> I need to revert this. It breaks the site build.
>>
>> Ralph
>>
>> On Jul 24, 2011, at 6:30 AM, Christian Grobmeier wrote:
>>
>>> Thanks, it helped.
>>>
>>> Found out that m3 eclipse plugin 2.8 is not so good with relative
>>> paths as 2.7 was.
>>> i replaced the ".." path in the vfs-core with ${basedir}
>>>
>>> Hope thats ok for everybody, I am not a core committer to this component
>>>
>>>
>>> On Sun, Jul 24, 2011 at 2:13 PM, Gary Gregory <garydgregory@gmail.com>
wrote:
>>>> I've not seen this exact issue but this kind of problem is not
>>>> uncommon with M3 compared to M2. You could try Running clean and then
>>>> upgrading to the latest common-parent. After that you can try
>>>> upgrading the plugins that blow up one at a time.  The catch 22 is
>>>> that newer plugins might not work in M2.
>>>>
>>>> Gary
>>>>
>>>> On Jul 24, 2011, at 5:33, Christian Grobmeier <grobmeier@gmail.com>
wrote:
>>>>
>>>>> Just tried to build a eclipse project of vfs with mvn eclipse:eclipse
>>>>>
>>>>> My mvn version is 3.0.3. I get a weird error, so I am wondering if
>>>>> somebody has experienced it before (or something similar). I tried it
>>>>> from toplevel vfs and from core subfolder:
>>>>>
>>>>> $ mvn eclipse:eclipse
>>>>>
>>>>> ...
>>>>>
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [INFO] BUILD FAILURE
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [INFO] Total time: 2.151s
>>>>> [INFO] Finished at: Sun Jul 24 11:28:23 CEST 2011
>>>>> [INFO] Final Memory: 13M/81M
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [ERROR] Failed to execute goal
>>>>> org.apache.maven.plugins:maven-eclipse-plugin:2.8:eclipse
>>>>> (default-cli) on project commons-vfs2: Execution default-cli of goal
>>>>> org.apache.maven.plugins:maven-eclipse-plugin:2.8:eclipse failed:
>>>>> String index out of range: -5 -> [Help 1]
>>>>> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to
>>>>> execute goal org.apache.maven.plugins:maven-eclipse-plugin:2.8:eclipse
>>>>> (default-cli) on project commons-vfs2: Execution default-cli of goal
>>>>> org.apache.maven.plugins:maven-eclipse-plugin:2.8:eclipse failed:
>>>>> String index out of range: -5
>>>>>   at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:225)
>>>>>   at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
>>>>>   at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
>>>>>   at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
>>>>>   at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
>>>>>   at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
>>>>>   at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
>>>>>   at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
>>>>>   at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
>>>>>   at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
>>>>>   at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
>>>>>   at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
>>>>>   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>>>   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>>>>   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>>>   at java.lang.reflect.Method.invoke(Method.java:597)
>>>>>   at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
>>>>>   at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
>>>>>   at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
>>>>>   at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
>>>>> Caused by: org.apache.maven.plugin.PluginExecutionException: Execution
>>>>> default-cli of goal
>>>>> org.apache.maven.plugins:maven-eclipse-plugin:2.8:eclipse failed:
>>>>> String index out of range: -5
>>>>>   at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:110)
>>>>>   at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
>>>>>   ... 19 more
>>>>> Caused by: java.lang.StringIndexOutOfBoundsException: String index out
>>>>> of range: -5
>>>>>   at java.lang.String.substring(String.java:1937)
>>>>>   at java.lang.String.substring(String.java:1904)
>>>>>   at org.apache.maven.plugin.eclipse.writers.EclipseSettingsWriter.write(EclipseSettingsWriter.java:111)
>>>>>   at org.apache.maven.plugin.eclipse.EclipsePlugin.writeConfiguration(EclipsePlugin.java:1113)
>>>>>   at org.apache.maven.plugin.ide.AbstractIdeSupportMojo.execute(AbstractIdeSupportMojo.java:511)
>>>>>   at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
>>>>>   ... 20 more
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> http://www.grobmeier.de
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>



-- 
http://www.grobmeier.de

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message