commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Benson <gudnabr...@gmail.com>
Subject Re: [BCEL] Next release
Date Mon, 18 Jul 2011 16:55:17 GMT
On Mon, Jul 18, 2011 at 11:47 AM, Dave Brosius <dbrosius@apache.org> wrote:
> I'm all for it. But there needs to be a decision which seems clear cut to me. There is
code in the code base (by accident--i suppose) now that requires 1.5. Previously we didn't
have that requirement, so pushing out a release means raising the minimum to 1.5. My vote
is lets do it two both. But everyone should be clear about this decision. Do we call it BCEL
6 because of this?dave   ----- Original Message -----From: &quot;Martin von Gagern&quot;
>;martin@von-gagern.net

Did existing APIs change, or is the Java 5 requirement an
implementation detail?  As I recall our policy in Commons is that an
upgrade to the required Java version does not in and of itself require
a major version bump so long as the code remains binary compatible.

Matt

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message