commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: [compress] Require Java5?
Date Thu, 21 Jul 2011 08:44:05 GMT
On 2011-07-21, Christian Grobmeier wrote:

> If we lift up to 1.5 as a minimum what about lifting to compress 2.0?

Depends on what we want to do.  If we want to break BWC by introducing
genrics, then let's do that.  I am currently withholding some work I
started to get the permissions stuff straightened because the API would
look quite different with enums.

On top Java5 would give us a pack200 compressor mor or less for free,
but this could be done without breaking APIs as well.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message