commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: [compress] Require Java5?
Date Mon, 25 Jul 2011 10:28:36 GMT
On 2011-07-21, sebb wrote:

> However just doing that without adding @Override and minimal generics
> will result in compilation warnings; it seems wromg to release source
> that does not compile cleanly.

The zip64 branch now requires Java5 but I'm having a hard time seeing
any compiler warnings.  The compiler plugin in commons-parent doesn't
allow me to set showWarnings and my clumsy attempts to override the
configuration in my pom have all failed so far (as has running mvn with
-Dmaven.compiler.showWarnings) - I'm outside of my Maven Fu.

So far I don't see a single warning which must be wrong.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message