commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <garydgreg...@gmail.com>
Subject Re: [lang] Time for RC3?
Date Mon, 04 Jul 2011 14:17:05 GMT
On Jul 4, 2011, at 6:28, Stephen Colebourne <scolebourne@joda.org> wrote:

> On 3 July 2011 19:07, Gary Gregory <garydgregory@gmail.com> wrote:
>>
>> http://markmail.org/message/ml7efpvqezysvs2p?q=Validate+list:org%2Eapache%2Ecommons%2Edev/
>>
>> Since this has gone quiet, I was going to follow through and rename the
>> validate* method (which are all @since 3.0) to check*. Someone else like it
>> it ;)
>>
>> But have two different verbs is smelly: Validate.check*(), As I mention in
>> the thread, a validator validates a state, so I like best:
>> Validator.validate*().
>>
>> But changing an existing class name seems more controversial and possibly
>> more trouble than it is worth. If it were just up to me, I would just bite
>> the bullet and do it for the sake of nice and pretty, but I am concerned
>> about downstream users.
>
> I have reviewed Validate, and am happy with it as currently written.
> It is also widely used, so I would recommend against change.
>
> It is an "assertion" class to replace the assert keyword in Java. The
> class name and method names all read OK in that context.
>

OK then.

Gary

> Stephen
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message